Subject: port-vax/12918: /dev/random still doesn't work on NetBSD/VAX
To: None <>
From: None <>
List: netbsd-bugs
Date: 05/12/2001 12:04:26
>Number:         12918
>Category:       port-vax
>Synopsis:       /dev/random still doesn't work on NetBSD/VAX
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-vax-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat May 12 12:04:00 PDT 2001
>Originator:     M J Dowden
>Release:        NetBSD/VAX 1.5 and 1.51Beta
notung% uname -a
NetBSD notung 1.5.1_BETA NetBSD 1.5.1_BETA (GENERIC) #2: Mon Apr  9 16:33:16 PDT
 2001     matt@cougar.local:/u1/kobj/GENERIC vax
/dev/random is not configured; this makes most security software non-functional

notung% gpg --gen-random 2 1024
gpg: fatal: can't open /dev/random: Device not configured
secmem usage: 1408/1408 bytes in 2/2 blocks of pool 1408/16384
try to extract random numbers from /dev/random
I believe that it is a kernel configuration issue