Subject: pkg/12906: mysql-client must build with --with-mit-threads
To: None <>
From: None <>
List: netbsd-bugs
Date: 05/10/2001 23:20:18
>Number:         12906
>Category:       pkg
>Synopsis:       --with-mit-threads is necessary to remove UNIX socket support
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu May 10 20:21:00 PDT 2001
>Originator:     Michael Richardson
>Release:        NetBSD 1.5.1_BETA
Canadian Commuter Challenge Project -- GNU Potato Caboose 
System: NetBSD 1.5.1_BETA NetBSD 1.5.1_BETA (XTERM) #0: Tue May 8 15:45:57 EDT 2001 i386
Architecture: i386

	As we built with mit-threads on the server side, we can not use
	UNIX domain sockets with it. (Seems bogus, at least it is true
	with 3.23.22). When we built the client seperately, we don't
	learn that we would use mit-threads, so we have to tell it explicitely.
	build client and server, use "mysql -uroot -p"
Index: Makefile
RCS file: /cvsroot/pkgsrc/databases/mysql-client/Makefile,v
retrieving revision 1.14
diff -w -u -r1.14 Makefile
--- Makefile    2001/05/02 08:22:28     1.14
+++ Makefile    2001/05/11 03:20:05
@@ -9,6 +9,7 @@
 CONFIGURE_ARGS+=       --without-server
+CONFIGURE_ARGS+=       --with-mit-threads
 .if exists(/usr/include/readline.h) || exists(/usr/include/readline/readline.h)
 CONFIGURE_ENV+=                readline_lib="edit"