Subject: pkg/12891: gzip comes with 1.4.x can't handle bzip2.
To: None <>
From: SUNAGAWA Keiki <>
List: netbsd-bugs
Date: 05/10/2001 16:03:57
>Number:         12891
>Category:       pkg
>Synopsis:       older gzip can't handle bzip2 archives.
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu May 10 00:03:00 PDT 2001
>Originator:     SUNAGAWA Keiki
>Release:        latest pkgsrc, 1.4.x system
	Yokogawa Electric Corporation

System: NetBSD vivid 1.4.1 NetBSD 1.4.1 (GENERIC) #1: Tue Aug 10 00:03:09 MEST 1999 fvdl@struis:/usr/src/sys/arch/i386/compile/GENERIC i386


	Older versions of our gzip do not handle bzip2 archives, so some
	packages fail in extract stage.
	Reading CVS log for src/gnu/usr.bin/gzip, all 1.4.x versions should be
	affected by this problem.


	chdir to /usr/pkgsrc/fonts/jisx0208fonts and do make.

===> check-depends [jisx0208fonts-20010112] ===> Validating dependencies for jisx0208fonts-20010112
WARNING: Unknown object format for installed package perl>=5.0 - continuing
=> Checksum OK for elisat10.tar.gz.
=> Checksum OK for Kappa20-0.3.tar.gz.
=> Checksum OK for knj10-1.1.tar.gz.
=> Checksum OK for 6x12.tar.gz.
=> Checksum OK for shinonome12-1.0.8.tar.bz2.
===> real-extract [jisx0208fonts-20010112] ===> Extracting for jisx0208fonts-20010112
===> install-depends [jisx0208fonts-20010112] ===> Required installed package gmake-3.79.1: gmake-3.79.1 found
WARNING: Unknown object format for installed package perl>=5.0 - continuing
===> install-depends [jisx0208fonts-20010112] ===> Required installed package perl>=5.0: perl-5.00404 found

gzcat: /a/distfiles//shinonome12-1.0.8.tar.bz2: not in gzip format
/bin/mkdir -p /a/work/NetBSD-cvs/pkgsrc/fonts/jisx0208fonts/work.i386/jisx0208fonts-20010112
/bin/cp /a/work/NetBSD-cvs/pkgsrc/fonts/jisx0208fonts/files/Makefile /a/work/NetBSD-cvs/pkgsrc/fonts/jisx0208fonts/work.i386/jisx0208fonts-20010112
cd: can't cd to /a/work/NetBSD-cvs/pkgsrc/fonts/jisx0208fonts/work.i386/shinonome12-1.0.8
*** Error code 2

*** Error code 1

*** Error code 1

	Dunno.  Should we add pkgsrc/pkgtools/bzip2 or some and depend it?