Subject: pkg/12146: {glib,gtk}-config --version is wrong
To: None <>
From: Dan Winship <>
List: netbsd-bugs
Date: 02/07/2001 07:07:23
>Number:         12146
>Category:       pkg
>Synopsis:       {glib,gtk}-config --version is wrong
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Feb 07 07:10:01 PST 2001
>Originator:     Dan Winship
>Release:        current pkgsrc
Ximian, Inc.
System: NetBSD 1.4X NetBSD 1.4X (MONKEY) #1: Thu Jun 1 10:59:26 EDT 2000 i386

	"gtk-config --version" and "glib-config --version" return
	the wrong numbers:

danw@twelve-monkeys:~> pkg_info -I glib gtk+
glib-1.2.8          Some useful routines for C programming
gtk+-1.2.8          Gimp toolkit. Libraries for building X11 user interfaces
danw@twelve-monkeys:~> glib-config --version
danw@twelve-monkeys:~> gtk-config --version

	The version info in their configure scripts are being patched
	for reasons I'm not quite sure about (presumably having to do
	with shlib stuff) and this is leaking into the config scripts.