Subject: port-i386/11926: gif tunneling and linux compat
To: None <>
From: None <>
List: netbsd-bugs
Date: 01/10/2001 03:38:17
>Number:         11926
>Category:       port-i386
>Synopsis:       gif tunneling and linux compat
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    port-i386-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 10 03:38:01 PST 2001
>Originator:     Murray Armfield
>Release:        NetBSD-1.5
System: NetBSD tensor 1.5 NetBSD 1.5 (TENSORDBG) #7: Thu Jan 4 16:56:24 EST 2001 i386

	I have been using a program called Citrix ICA client for Linux with the linux emulation provided by NetBSD and the pkgsrc packages for the suse version of Linux. The program has been working fantastically.
	Recently I upgraded the pkgsrc suse packages from suse63 to suse64. With this it killed my Citrix ICA client for Linux, but not completely, only when you attempt to connect to a Citrix server. I have couple of other NetBSD-1.5 boxes so I tried the program there as well. Worked fine in suse64 environment.
	The issue was uncovered after taking this up with the person who upgraded suse to suse64. We discovered that rebuilding a kernel with gif support off removed this problem and the Citrix ICA client for Linux worked fine again. Hence some issue with the networking area of one of my machines. The machine that is having trouble is an HP omnibook xe2-dc. It has a Xircom CreditCard 10/100, CE3-10/100 network card.
	Build a kernel with gif tunneling enabled on my notebook.
	Remove default laptop kernel.
	Build GENERIC_laptop kernel with gif tunneling disabled.