Subject: pkg/11901: "sun-jre" package is not compatible with "jdk" package.
To: None <>
From: Matthias Scheler <>
List: netbsd-bugs
Date: 01/06/2001 01:08:14
>Number:         11901
>Category:       pkg
>Synopsis:       "sun-jre" package is not compatible with "jdk" package.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 06 01:08:00 PST 2001
>Release:        2001/01/06
Matthias Scheler                               
System: NetBSD 1.5Q NetBSD 1.5Q (LYSSA) #0: Fri Jan 5 12:53:55 CET 2001 i386
Architecture: i386
Machine: i386

"" treats "sun-jre" as a fully compatible replacement for the
"jdk" package. But because of the different directory layout the Java
interpreter is not at the correct location.

Try to use "${JAVA_HOME}/bin/java" with "sun-jre" installed.

Either depend on "sun-jdk" or install to "${LOCALBASE}/java".