Subject: pkg/11528: lilypond package fails with python2.0 because of missing "find" module
To: None <>
From: Bernd Sieker <>
List: netbsd-bugs
Date: 11/19/2000 21:29:12
>Number:         11528
>Category:       pkg
>Synopsis:       print/lilypond pkg needs "find" python module which is not in python2.0
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Nov 19 21:29:00 PST 2000
>Originator:     Bernd Sieker
>Release:        NetBSD-1.5
Bernd Sieker

Of course it runs NetBSD
System: NetBSD boa 1.5 NetBSD 1.5 (BOA) #0: Fri Nov 17 15:12:48 CET 2000 bernd@boa:/usr/src/sys/arch/i386/compile/BOA i386

	The lilypond package (musical score typesetting using TeX) fails
to build with python2.0; it tries to import a "find" module, which does
not seem to be part of python2.0. It was included in python1.5, and
lilypond built fine with that. I have no idea of python and so don't
know how to cure it.

Here's the output of make:

===> Required installed package python>=1.5.2: python-2.0 found
/usr/pkg/bin/python ../buildscripts/ --output out/feta-braces11.pfa out/feta-braces11.0
Traceback (most recent call last):
  File "../buildscripts/", line 16, in ?
    import find
ImportError: No module named find
gmake[1]: *** [out/feta-braces11.pfa] Error 1
gmake[1]: Leaving directory `/usr/pkgsrc/print/lilypond/work.i386/lilypond-1.3.86/mf'
gmake: *** [all] Error 2

	Try to build the lilypond package with python2.0 installed instead
of python1.5

	A workaround might be to install an old python1.5 binary package,
other than that I have no idea.