Subject: port-alpha/10455: Occasional "Undefined PLT symbol" messages from pine
To: None <>
From: Dave Huang <>
List: netbsd-bugs
Date: 06/26/2000 13:45:16
>Number:         10455
>Category:       port-alpha
>Synopsis:       Occasional "Undefined PLT symbol" messages from pine
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    port-alpha-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jun 26 13:46:00 PDT 2000
>Originator:     Dave Huang
>Release:        NetBSD 1.5_ALPHA as of June 25, 2000
Name: Dave Huang     |   Mammal, mammal / their names are called /
INet:   |   they raise a paw / the bat, the cat /
FurryMUCK: Dahan     |   dolphin and dog / koala bear and hog -- TMBG
Dahan: Hani G Y+C 24 Y++ L+++ W- C++ T++ A+ E+ S++ V++ F- Q+++ P+ B+ PA+ PL++
System: NetBSD 1.5_ALPHA NetBSD 1.5_ALPHA (YERFABLE) #99: Sun Jun 25 15:23:44 CDT 2000 alpha

	When saving attachments or sending attachments in pine, pine often
dies with messages like:
main program: Undefined PLT symbol "fwrite" (reloc type = 26, symnum = 126)

The exact message varies; I seem to remember seeing "strcpy" and/or
"strlen" as the symbol too. When sending attachments,
main program: Undefined PLT symbol "fread" (reloc type = 26, symnum = 41)
is a common error.

The error doesn't consistently happen, but larger attachments are more
likely to trigger the problem. In fact, I've tried to save a 1.7MB
attachment ten times, without any success. With smaller attachments
(100K or so), it'll usually work after a few tries (but I usually just
pipe to munpack now).

This has been going on for quite some time; I originally complained
about it in NetBSD 1.4P (November 29)
It's been reported by others too:

I'm using pine-4.21 from pkgsrc, compiled November 25, 1999. I haven't
tried recompiling it, but I can give that a shot and see what
happens. However, the same binary worked just fine with older kernels.

Kernel and userland compiled on June 25, 2000.

	Try to save or send a large attachment in pine.
	No idea... some obscure pmap problem still lurking about?