Subject: install/10435: sysinst-upgrade gets confused if /etc.old exists
To: None <>
From: Hal Murray <>
List: netbsd-bugs
Date: 06/25/2000 00:02:11
>Number:         10435
>Category:       install
>Synopsis:       sysinst-upgrade gets confused if /etc.old exists
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jun 25 00:03:00 PDT 2000
>Originator:     Hal Murray
>Release:        NetBSD 1.5_ALPHA, 20000620-1.5
        Systems Research Center, Compaq Computer Corporation
        Install floppies, Alpha 600au


        I tried to do an upgrade.  sysinst (correctly) objected because 
        I already had an /etc.old on that disk.  So I did the mount, 
        rm, umount dance and tried again. 

        It did a full fsck on my /usr.  That's strange, it didn't 
        have any troubles the first try.  At the end, it asked me 
        if it should mark it clean [yn].  I said "y".  But then it 
        complained about not being able to mount it. 
        Create /etc.old
        Try to upgrade
        After sysinst objects, do the mount, rm, and umount by hand.
        Try to upgrade again.

        work around: reboot and start over, possibly rebooting from 
        the disk to make sure things are clean.

        fix: ??