Subject: pkg/10404: openssh needs openssl 0.9.5a.
To: None <>
From: None <>
List: netbsd-bugs
Date: 06/20/2000 18:49:18
>Number:         10404
>Category:       pkg
>Synopsis:       openssh needs openssl 0.9.5a.
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 20 18:50:01 PDT 2000
>Originator:     Motoyuki Konno
>Release:        NetBSD-current
BSD Club
NetBSD asuka 1.4ZD NetBSD 1.4ZD (ASUKA $Revision: 1.16 $) #0:
Sun Jun 18 13:19:44 JST 2000     root@asuka:/usr/src/basesrc/sys/arch/i386/compile/ASUKA i386

openssh port requires openssl 0.9.5a or later. but, NetBSD system
default (recently imported to basesrc/crypto/dist/openssl) is
openssl 0.9.4.  So, we need a pkg version of openssl.

make openssl port on -current machine.

--- Makefile.old        Thu Jun 15 13:56:50 2000
+++ Makefile    Wed Jun 21 10:49:34 2000
@@ -15,9 +15,7 @@
 BUILD_DEPENDS+=                ${LOCALBASE}/bin/perl:../../lang/perl5
 BUILD_DEPENDS+=                autoreconf:../../devel/autoconf
-.if !exists(/usr/include/openssl/rsa.h)
 DEPENDS+=              openssl-[0-9]*:../../security/openssl
 CONFLICTS=             ssh-[0-9]* ssh6-[0-9]*