Subject: Re: port-i386/7807: 1.4 install floppy has "Bus-Master DMA error:
To: Chris G. Demetriou <>
From: Ed Gould <>
List: netbsd-bugs
Date: 06/23/1999 16:43:34
> Manuel Bouyer <> writes:
>>On Fri, Jun 18, 1999 at 02:29:46AM -0700, wrote:
>>> pciide0:0:0: lost interrupt 
>>>         type: ata
>>>         c_bcount: 65536
>>>         c_skip: 0
>>> pciide0:0:0: Bus-Master DMA error: missing interrupt, status=0x21
>>> wd0e: DMA error writing fsbn 129184 of 129184-129311 (wd0 bn 764224; cn 
758 tn 2
>>>  sn 34), retrying
>>> wd0: soft error (corrected)
>>> It's worth noting that these errors do appear to be safely corrected,
>>> i.e. installation continues and nothing _appears_ to be wrong
>>> with the installed bits (though i've not tried to verify them
>>> closely enough to be sure).
>>I'm pretty sure these errors are caused by flacky hardware which don't 
> >DMA properly.
> While this may be true, i'm hesitant to believe it.

I don't believe it either.  I saw the same problem (with effectively the same 
hardware).  I'm still running 1.3.2 on this machine, with the PCI IDE patches 
installed, without failures.