Subject: pkg/6376: Tosha uses private libscsi
To: None <>
From: John Ruschmeyer <>
List: netbsd-bugs
Date: 10/29/1998 17:08:22
>Number:         6376
>Category:       pkg
>Synopsis:       Tosha uses private libscsi
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Thu Oct 29 14:20:02 1998
>Originator:     John Ruschmeyer
	Many little piles
>Release:        NetBSD-current
System: NetBSD tigger 1.3.2 NetBSD 1.3.2 (TIGTEST) #39: Sun Oct 11 11:23:14 PDT 1998 root@tigger:/usr/src/sys/arch/i386/compile/TIGTEST i386

	Tosha (pkgsrc/audio/tosha) installs a copy of the SCSI library
	(devel/libscsi) as part of patch-aa. This copy of libscsi is
	apparently from the OpenBSD distribution originally, but appears
	to be effectively the same as the library installed when the
	the libscsi package is installed.

	If the tosha Makefile is manually edited to use libscsi, the
	software still builds cleanly and appears to run the same.

	Unpack sources, apply netbsd fixes, manually edit Makefile to 
	remove references to scsi.o and insert '-lscsi' on link line.

	Test resulting build.
	At the simplest level, Tosha should be made to depend on
	libscsi and the patches reworked accordingly.

	There is a bigger potential issue with the currentness of
	the libscsi package vs. the scsi software originally
	installed in the Tosha patches. Obviously, we want to 
	install the most current and most "correct" one, but as
	part of Tosha and as libscsi.