Subject: port-arm32/6342: netbsd-current/arm32 stops after autoconfig is done (shark)
To: None <>
From: None <>
List: netbsd-bugs
Date: 10/22/1998 09:19:42
>Number:         6342
>Category:       port-arm32
>Synopsis:       netbsd-current/arm32 stops after autoconfig is done (shark)
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Oct 22 00:35:00 1998
>Originator:     Matthias Pfaller
Matthias Pfaller                            Software Entwicklung
marco Systemanalyse und Entwicklung GmbH    Tel   +49 8131 5161-41
Hans-Böckler-Str. 2, D 85221 Dachau         Fax   +49 8131 5161-66                        Email
>Release:        current-98/10/19
System: NetBSD lethe 1.3H NetBSD 1.3H (LETHE) #28: Wed Sep 30 14:27:56 CEST 1998 leo@lethe:/usr/src/sys/arch/arm32/compile/LETHE arm32

When booting a kernel build from the 98/10/19 -current sources on a
shark, it just stops after finishing autoconfiguration. I have set
wdcdebug_wd_mask and wdcdebug_atapi_mask to 0xffffffff. When booting I
get the following messages:

	DNARD Rev. 5, 08:00:2b:81:64:13 , 48 MB memory
	Open Firmware  Built February 25, 1998 17:19:25
	Copyright 1997 FirmWorks  All Rights Reserved

	Rebooting with command: boot disk:\ -s
	Boot device: /isa/ide/disk@0:\  Arguments: -s
	ddb: [ preserving 101460 bytes of netbsd symbol table ]
	Copyright (c) 1996, 1997, 1998
	    The NetBSD Foundation, Inc.  All rights reserved.
	Copyright (c) 1982, 1986, 1989, 1991, 1993
	    The Regents of the University of California.  All rights reserved.

	Number of pages to handle = 12288
	pmap_init: 31000 bytes (2d53 pgs)
	NetBSD 1.3H (LETHE) #33: Mon Oct 19 23:16:25 CEST 1998
	real mem  = 50331648
	avail mem = 43253760
	using 307 buffers containing 2621440 bytes of memory
	mainbus0 (root)
	cpu0 at mainbus0: SA-110 rev 3 DC enabled IC enabled WB enabled EABT
	ofbus0 (root)
	ofbus1 at ofbus0 (vlbus)
	ofisa0 at ofbus1 (isa)
	dma-controller@i00 at ofisa0 not configured
	interrupt-controller@i20 at ofisa0 not configured
	timer@i40 at ofisa0 not configured
	configuration@i15c at ofisa0 not configured
	com0 at ofisa0 (serial@i3f8): ns16550a, working fifo
	com0: console
	lpt0 at ofisa0 (parallel@i378)WARNING: irq 7 not level triggered

	ofbus2 at ofisa0 (8042@i60)
	ofisapc0 at ofbus2 (keyboard@)
	kbc command: 0
	mouse@aux at ofbus2 not configured
	power@i380 at ofisa0 not configured
	ofbus3 at ofisa0 (gpio@i3e0)
	eeprom at ofbus3 not configured
	ofrtc0 at ofisa0 (rtc@i70): rtc
	ofisascr0 at ofisa0 (scr@i24)
	scr0 at ofisascr0
	com1 at ofisa0 (ir@i2f8): ns16550a, working fifo
	cs0 at ofisa0 (ethernet@i300): CRUS,CS8900
	cs0: CS8900 rev. F, address 08:00:2b:81:64:13, media UTP
	joy0 at ofisa0 (game@i201): ESST,game
	joy0: joystick not connected
	midi@i330 at ofisa0 not configured
	ess0 at ofisa0 (sound@i220): ESST,es1887-codec
	ess0 ESS Technology ES1887 [version 0x688b]
	audio0 at ess0
	opl0 at ess0: model OPL3
	midi0 at opl0: <Yamaha OPL3>
	wdc0 at ofisa0 (ide@i1f0)
	wd0 at wdc0 channel 0 drive 0wdattach
	: <HITACHI_DK225A-21>
	wd0: using 16-sector pio transfers, lba mode
	wd0: 2061MB, 4188 cyl, 16 head, 63 sec, 512 bytes/sect x 4221504 sectors
	wd0: atap_dmatiming_mimi=120, atap_dmatiming_recom=120
	wd0: PIO mode 4, DMA mode 2
	pci at ofbus1 not configured
	display@it3b0 at ofbus1 not configured
	ofrom0 at ofbus0 (flash@7000000): 0x7000000-0x707ffff
	ofrom1 at ofbus0 (romcard@10000000): 0x10000000-0x10ffffff
	ipl_bio=ffffbfff ipl_net=ffffbfdf ipl_tty=ffffbf5f ipl_imp=ffffbf5f
	ipl_audio=ffff3d5f ipl_imp=ffff3d5f ipl_high=ffff3d5f ipl_serial=ffff3d47
	clock: hz=64 stathz = 0 profhz = 0
	boot device: <unknown>
	root on wd0a dumps on wd0b
	wdstrategy (wd0)
	wdstart wd0
	wdc_ata_bio_start wdc0:0:0

	boot a -current kernel on a shark.