Subject: odd disk behaviour with 1.3 on pc532
To: None <netbsd-bugs@NetBSD.ORG>
From: Der Beagle <parsely!sopwith.UUCP!snoopy@ucbvax.Berkeley.EDU>
List: netbsd-bugs
Date: 02/14/1998 17:32:04
I recently upgraded my pc532 box from NetBSD 1.1 to 1.3.

The box has three SCSI disks.  These worked fine
under 1.1.  Under 1.3, the third disk (sd2) behaves

	- writing a file on a mounted filesystem (FFS)
	causes the entire contents of that directory to
	become invisable, until the filesystem is unmounted
	and remounted.  The data written then shows up.

	- writing to a partition using the raw device fails:

machup # dd if=/dev/zero of=/dev/sd2a bs=8k count=1
1+0 records in
1+0 records out
8192 bytes transferred in 1 secs (8192 bytes/sec)
machup # dd if=/dev/zero of=/dev/rsd2a bs=8k count=1
dd: /dev/rsd2a: end of device
1+0 records in
0+0 records out
0 bytes transferred in 1 secs (0 bytes/sec)
machup # 

	In this case, the data written does not make it
	out to the disk.

The sd0 and sd1 disks work fine.  The /dev entries appear to
be correct.  I've tried zeroing out the first part of the disk
and then writing a fresh disklabel.  I've tried building a kernel
with explicit entries for sd0, sd1 and sd2 rather than depending
on wildcarding.