Subject: port-alpha/4903: using DEC's isp10X0 F/W fails to fireup correctly after boot
To: None <>
From: Matthew Jacob <>
List: netbsd-bugs
Date: 01/27/1998 22:19:03
>Number:         4903
>Category:       port-alpha
>Synopsis:       using DEC's isp10X0 F/W fails to fireup correctly after boot
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jan 27 22:35:00 1998
>Originator:     Matthew Jacob
Feral Software
>Release:        1.3B

On DEC systems (500s, I believe) that now have ROM f/w for the
onboard ISP SCSI chips that is of rev 5.1 or later.


Mail from cgd:

+++From  Thu Jan 22 17:57:49 1998
+++Cc: "Chris G. Demetriou" <>
+++From: "Chris G. Demetriou" <>
+++Subject: problems with isp1020 in AlphaStation 500.
+++Date: Thu, 22 Jan 98 17:57:24 -0800
+++So, I just got an AlphaStation 500 (333MHz), and i'm having some
+++problems with the ISP driver.  In particular, it's reporting "commands
+++really timed out!" for all post-autoconfig accesses to the disk.
+++isp0 configures at kn20aa irq 12, seems to find the attached disk and
+++CD-ROM correctly, etc.
+++At first I tried it with SRM v6.4-3, dated 1/24/97, which apparently
+++contained "ROM F/W Revision 5.1".  I figured it might be the
+++console, so i then tried it with the latest firmware from the public
+++FTP site, which contains SRM v6.6-2 (i didn't write down the date) and
+++causes the ISP to report ROM formware version 5.27
+++I don't really have a clue as to what's going on here, and have no way
+++to test my one hypothesis: that the firmware installed by SRM is
+++incompatible with the NetBSD driver, and the firmware version tests in
+++the driver (which seem to keep the kernel's firmware from being
+++installed if the ROM firmware version is higher -- and 5.1 and 5.27
+++are higher than 2.10) cause the kernel's firmware from being
+++Does that sound like a reasonable hypothesis?
+++If it is, I don't understand how Jason's AlphaStation 500 works... 8-)
+++Any suggestions on how I can debug this?  I can currently probably
+++compile NetBSD/alpha kernels, but cannot easily net-boot, nor can I
+++make NetBSD/alpha boot floppies.

I dunno why this breaks, but it does. Todos el mundos is on PCI f/w
rev 2.10 (or a bit later for some of the fast posting that Qlogic
is now doing) for the 10X0 adapters. DEC has their own series. I
had been leaving it alone in terms of not downloading 2.10 on top
of 5.1, but this may not be sufficient- it has worked for Jason and
I, but hasn't for Chris. I'm speculating that DEC may have actually
changed the API between the f/w and the OS driver.

	See cgd.
	I think chris' suggestion from separate mail is correct and to
always download f/w (he also suggested a compilation switch or some
other switches, but...)- Essentially this chipset is in late support phase,
and the amount of new f/w coming down the path is pretty limited, so to
avoid grief, I think I should just eliminate the check for f/w revs and
always download the f/w- particularly if the API between the f/w and the
OS driver has to stay matched.