Subject: Re: bin/3982: ftp ignores eofc
To: der Mouse <mouse@Rodents.Montreal.QC.CA>
From: Perry E. Metzger <>
List: netbsd-bugs
Date: 01/02/1998 10:46:46
der Mouse writes:
> On
> > Date: Wed, 13 Aug 1997 11:38:18 -0400
> Perry quoted from my PR bin/3982 and wrote
> >>> Synopsis:       ftp ignores eofc
> > Fixed in current, Mr. Mouse.  You haven't updated your source tree
> > lately...
> At the time, I hadn't.
> I now have.  And I find that the problem is there (still or again,
> whichever, though I suspect it's "still") in an ftp binary built from
> the sup of Dec 31.

It was broken for several weeks while Luke was doing all his evil
changes to FTP, but lots of people (including me) complained and it is
now functioning as before.

I just typed "ftp" and then typed "^D" and it worked Just Fine. There
is no problem in 1.3 or in the head.

> When I run ftp, I see the following.  (I typed ^Z at each of the first
> two "ftp> " prompts, then RETURN when nothing happened.)

You are probably having an interaction with the command line editing
stuff. You didn't specify that you had set EOF to something odd (^Z is