Subject: port-i386/4592: 3c509 found twice
To: None <gnats-bugs@NetBSD.ORG>
From: None <>
List: netbsd-bugs
Date: 11/28/1997 16:55:58
>Number:         4592
>Category:       port-i386
>Synopsis:       3c509 found twice
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Nov 27 22:05:02 1997
>Originator:     Simon J. Gerraty
>Release:        NetBSD-1.3_ALPHA (971124)
System: NetBSD 1.3_ALPHA (INSTALL) #37: Tue Nov 25 13:01:03 MET 1997
Architecture: i386

As the /kern/msgbuf (very handy that!) content shows, the 3c509 is
found twice by the GENERIC kernel.

The BIOS records the 3C509 card as PNP if that helps.

Copyright (c) 1996, 1997 The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 1.3_ALPHA (INSTALL) #37: Tue Nov 25 13:01:03 MET 1997
cpu0: family 5 model 2 step 5
cpu0: Intel Pentium (P54C) (586-class)
real mem  = 66715648
avail mem = 58732544
using 840 buffers containing 3440640 bytes of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x8086 product 0x122d (rev. 0x02)
pcib0 at pci0 dev 7 function 0
pcib0: vendor 0x8086 product 0x122e (rev. 0x02)
vendor 0x8086 product 0x1230 (IDE mass storage, interface 0x80, revision 0x02) at pci0 dev 7 function 1 not configured
vendor 0x5333 product 0x8811 (VGA display) at pci0 dev 12 function 0 not configured
isa0 at pcib0
ep0 at isa0 port 0x300-0x30f irq 11: 3Com 3C509 Ethernet
ep0: MAC address 00:a0:24:02:63:72
ep0: 8KB byte-wide FIFO, 5:3 Rx:Tx split, utp/aui (default utp)
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
sea0: board type unknown at address 0xc8000
wdc0 at isa0 port 0x1f0-0x1f7 irq 14
atapibus0 at wdc0
wd0 at wdc0 drive 0: <Conner Peripherals 540MB - CFS541A>
wd0: 515MB, 1048 cyl, 16 head, 63 sec, 512 bytes/sec
wd0: using 16-sector 16-bit pio transfers, lba addressing
wdc1 at isa0 port 0x170-0x177 irq 15
atapibus1 at wdc1
Warning drive 0 returned 142/512 of indentify device data
cd0 at atapibus1 drive 0: <NEC                 CD-ROM DRIVE:280, , 3.08> type 5 cdrom removable
npx0 at isa0 port 0xf0-0xff: using exception 16
pc0 at isa0 port 0x60-0x6f irq 1: color
pc0: console
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0 at isa0 port 0x279: read port 0x203
ep1 at isapnp0 port 0x210/16 irq 5
ep1: 3Com 3C509B EtherLink III 
ep1: MAC address 00:a0:24:02:63:72
ep1: 8KB byte-wide FIFO, 5:3 Rx:Tx split, utp/aui (default utp)
biomask c040 netmask c860 ttymask c862
md0: internal 1537K image area
boot device: fd0
root on md0a dumps on md0b
mountroot: trying ffs...
root file system type: ffs
init: copying out flags `-s' 3
init: copying out path `/sbin/init' 11

Attempting to ifconfig ep0 hangs the machine.  
However, ep1 works fine.

Boot the install floppy on a PCI machine with 3c509 installed.