Subject: kern/3141: port probing in "if_de.c" broken
To: None <>
From: Matthias Scheler <>
List: netbsd-bugs
Date: 01/26/1997 00:53:34
>Number:         3141
>Category:       kern
>Synopsis:       port probing in "if_de.c" broken
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people (Kernel Bug People)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 25 16:05:02 1997
>Originator:     Matthias Scheler
Matthias Scheler
>Release:        970124
System: NetBSD lyssa 1.2B NetBSD 1.2B (LYSSA) #1: Sat Jan 25 16:18:23 MET 1997 tron@lyssa:/usr/src/sys/arch/i386/compile/LYSSA i386

I have two ethernet boards in a P133 running NetBSD-current:
A ReadyLINK ENET32-PCI (DEC 21040, de0) and a D-Link DFE-500TX (DEC 21140,
de1). The ReadyLINK is connected to a TP HUB, the D-Link is unused. Until
I updated from 961231 to 970124 sources both ports of the ReadyLINK worked
absolutely perfect, the initial auto probing always found the correct one.
When I try to boot my machine with a kernel based on 970124 sources and a
TP cable connected to the ReadyLINK I get the following message again and
again and the system startup is terribly slowed down:
 de0: enabling 10baseT port
 de0: link down: cable problem?
As soon as I unplug the TP cable the messages stop, the system continues
to boot at normal speed and I get this message once:
 de0: autosense failed: cable problem?
If I connect a BNC cable before or after startup everything works fine.
I also tried the D-Link board in 10MBit mode with a TP cable and there
is no problem either. It's definitely not a hardware problem because
downgrading to the old kernel fixes the problem, too.

Connect a ReadyLINK ENET32-PCI (or maybe any DEC 21040 based board) with
a TP cable and reboot your system.

Sorry, I don't know.