Subject: kern/2339: kernel 'make depend' doesn't do libkern, libcompat dependencies.
To: None <gnats-bugs@NetBSD.ORG>
From: Chris G. Demetriou <>
List: netbsd-bugs
Date: 04/17/1996 22:14:10
>Number:         2339
>Category:       kern
>Synopsis:       'make depend' for kernels doesn't do libkern, libcompat depends
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    kern-bug-people (Kernel Bug People)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 17 22:35:05 1996
>Originator:     Chris G. Demetriou
Kernel Hackers 'r' Us
>Release:        NetBSD-current, 4/17/96
System: NetBSD 1.1B NetBSD 1.1B (SUN_LAMP) #74: Mon Apr 15 15:22:45 EDT 1996 i386

	saying 'make depend' in a kernel compile directory doesn't build
	dependencies for either libkern or libcompat.

	config a kernel.

	'make depend'

	Notice that no dependencies are build for libkern or libcompat.
	build them, change a file that they include, notice that they
	aren't rebuild.

	(None provided.)