Subject: bin/1955: route doesn't work propperly when default route exists
To: None <>
From: Peter Simons <>
List: netbsd-bugs
Date: 01/18/1996 00:21:21
>Number:         1955
>Category:       bin
>Synopsis:       route doesn't work propperly when default route exists
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    bin-bug-people (Utility Bug People)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 17 18:50:04 1996
>Originator:     Peter Simons
private Internet site
>Release:        NetBSD 1.1 GENRIC Kernel
System: NetBSD 1.1 NetBSD 1.1 (INSTALL) #0: Fri Nov 24 13:47:14 EST 1995 amiga

	My system is an Internet gateway for several other machines., the one routing the dial-in sites, is
	connected to via the Ariadne ethernet card. What
	I did was to configure ae0 using ifconfig, what worked fine.
	Then pppd was fired up and connected succesfully, setting the
	default route.

	After that, I started

	 $ route add -net phoenix -netmask

	to route the dial-in sites back to phoenix via ae0. After
	testing "netstat -r", though, I saw that this subnet is
	accessed via ppp0, the default route. I tried everything to
	make it be directed via ae0, but it didn't work.

	Everything worked fine after removing the default route,

	As a work-around, I just make sure that the subnet is routed
	_before_ pppd is started up.