Subject: kern/1877: pppd hangs
To: None <>
From: David Mazieres <>
List: netbsd-bugs
Date: 12/31/1995 14:10:22
>Number:         1877
>Category:       kern
>Synopsis:       PPP network interface hangs, pppd unkillable
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people (Kernel Bug People)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Dec 31 14:20:02 1995
>Originator:     David Mazieres
>Release:        1.1A, Dec 29 and later (possibly since Dec 22)
	486 with 16550A uarts (over which ppp goes), 8013 ethernet
        card, and IP forwarding turned on in the kernel.
System: NetBSD garage 1.1A NetBSD 1.1A (GARAGE) #7: Thu Dec 21 23:42:35 EST 1995 dm@garage:/u/obj/sys/arch/i386/compile/GARAGE i386  (This is my working kernel, the ones that do not work are Dec 29 and Dec 31.)

When I run either the current or the Dec. 21 version pppd with the
current kernel, it eventually hangs.  After a long time (typically
about 10 Megabytes or so have come in over the interface), I start
getting buffer full messages back from ping and traceroute.  The last
few times it seemed to happen when there was also heavy disk activity,
but I'm not sure if that was always the case.  Pppd itself is
unkillable when this happens (even with SIGKILL).

The problem goes away when I run my old (Dec. 21) kernel.
Semms to take about an hour of heavy activity to happen.  Someone else
with the same problem said it happened whenever he started trn and it
downloaded the active file.

When I boot the kernel I built from December 21 kernel sources, the
problem goes away.  This is obviously not a "fix", but may help in
tracking the problem down.  I noticed the problem when I upgraded to
a December 29th kernel, so the problem happened sometime between
December 21 and 29.