Subject: A bug with install disks. Does not find NCR 810 scsi.
To: None <netbsd-bugs@NetBSD.ORG,>
From: Cameron Blackwood <>
List: netbsd-bugs
Date: 11/22/1995 12:13:52
Much though I would like to install netbsd (and use send-pr for this
:), I find that I cant install netbsd, because it doesnt find my NCR
SCSI controller.

I think this is a problem with your autoconfig code, as linux finds
it and uses it ok. I tried both boot disks (although they both should
support it from my reading).

Newer versions of linux (1.3...) print lots of:
     Warning : Unknown PCI device.  Please read include/linux/pci.h 
upon booting, but it still works. Previous versions (1.2..) worked
without complaint.

Netbsd boots, but offers me NO choice of harddisk controller. :(
It seems to find everything else ok.

I assume that it is just the butchery required to get all the slots
working on my motherboard that is making the code fail, but I thought
I would mention it, because Linux is starting to annoy me at times.

  * NCR 53c810 pci/scsi chip
  * other details: #9 pci video, 4 serial ports, 16M ram, blah blah.
  * 486 motherboard, with 3 PCI/2 VLB/ 3 ISA slots (yes all 3).
The manual says: PCI/VLB 486 AL4 on the cover.
It has 1.1G inside. 
It runs Phoenix Dragon BIOS
It is a bizare motherboard that has 72 and 30 pin ram too.


 / `Rev Dr'       skeptic, virtual goth \
< [+61 3] 905 3403 or 809 1523                BSD Unix, C/C++, genetics, ATM >
 \ Monash University of Oz.    /
   ____ GCS d? p--- c++++ l u++ e++ m+ s/+ n- h f+? g+ w+++ t++ r++ y+ ____
"I have grown to womanhood in a world where the saner you are, the
madder you are made to appear." 
          --Hannah Nelson  and  Deena McKinney <MCKINNEY@UGA.CC.UGA.EDU>