Subject: Problems upgrading to 1.1_ALPHA on i386
To: None <netbsd-bugs@NetBSD.ORG>
From: Scott R. Burns <>
List: netbsd-bugs
Date: 11/13/1995 22:46:09
I have a NetBSD/i386 box at home which I use as my home file server. The
machine is a clone 466 with 16MB RAM, Adaptec 1542CF with a DEC RZ24
(400MB?)(system disk), DEC RZ28 (2.? GB), DEC TZ86 (? GB tape drive). This
machine is running NetBSD V1.0A from around June or July 95.

About 2-3 weeks ago I upgraded a DEC RZ26 (1 GB) drive to the RZ28. I then
beat up the SCSI bus while restoring from tape the RZ26 contents, installing
CorelDraw V6 (about 1.2 GB) over Samba and then backing up the entire
machine (1.6 GB) to tape. This worked great. Therefore I would assume the
SCSI bus is setup/term'd (one terminator on the external tape drive and one
on the last SCSI disk) OK.

This weekend I downloaded V1.1_ALPHA tar files dated Nov 11th. These are
under /usr/src which is linked to a partition on the new 2GB RZ28. My system
disk is the 400 MB RZ24.

These are my findings with the upgrade ( I am using a message posted by
Alistair Crooks) of Amdahl for my install instructions which worked for the
V1.0A build.

(**** Alistair can you have this file put up on the machine
so it is easy to find. The last we e-mailed I think your corporate firewalls
where being reorg'd and the URL I had no longer works :-( ).


===> xlint/xlint
cc -O -I/usr2/src/usr.bin/xlint/xlint/../lint1   -c xlint.c
cc -O -I/usr2/src/usr.bin/xlint/xlint/../lint1   -c /usr2/src/usr.bin/xlint/xlic
cc   -o xlint xlint.o mem.o 
nroff -mandoc lint.1 > lint.cat1
===> xlint/llib
lint -Cposix llib-lposix
lint: not found
*** Error code 1

*** Error code 1

*** Error code 1

===> ac
cc -O   -c ac.c
cc   -o ac ac.o 

Then later when building the world

===> rpc.bootparamd
cc -O -DYP   -c bootparamd.c
rm -f bootparam_prot.x
ln -s /usr/include/rpcsvc/bootparam_prot.x .
rm -f bootparam_prot.h
ln -s /usr/include/rpcsvc/bootparam_prot.h .
rpcgen -m -o bootparam_prot_svc.c bootparam_prot.x
cc -O -DYP   -c bootparam_prot_svc.c
bootparam_prot_svc.c:13: stropts.h: No such file or directory
*** Error code 1

*** Error code 1

===> atrun
cc -O -I/usr2/src/libexec/atrun/../../usr.bin/at   -c atrun.c
cc   -o atrun atrun.o 


My real problem is related to my SCSI sub-system. During the build, when
it's really hitting the disks hard I keep getting:

sd0(aha0:0:0): timed out
sd0(aha0:0:0): timed out
sd0(aha0:0:0): timedout aha0: not taking commands

I am not a real unix debugging god but it appears from the debugger that it
is in the aha_poll (spelling?) routine. Any major changes to the AHA1542CF
driver since the summer ? Any specific info you need from the debugger I get
dumped into during the crash ?

Sorry I have no send-pr access. Just thought you might want to know about
this before the release ;-)