Subject: port-i386/986: 20, 21 Apr kernels with pcvt breaking XF86 3.1.1
To: None <gnats-admin@NetBSD.ORG>
From: Scott Reynolds <scottr@Plexus.COM>
List: netbsd-bugs
Date: 04/21/1995 09:50:04
>Number:         986
>Category:       port-i386
>Synopsis:       20, 21 Apr kernels with pcvt breaking XF86 3.1.1
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Apr 21 09:50:02 1995
>Release:        NetBSD-current {20,21} Apr 1995
	NetBSD/i386 1.0A supped on 20 Apr 1995
	XFree86 3.1.1
	Aperture driver for XFree86 version 1.2
	All NetBSD binaries have been recompiled and installed
	Kernel uses vt0 for console driver
System: NetBSD aqua 1.0A NetBSD 1.0A (TGI) #25: Wed Apr 19 10:09:56 CDT 1995 root@aqua:/a/src/sys/arch/i386/compile/TGI i386

	When using pcvt with a kernel from 20 and 21 April, a text console
	fires up fine.  However, onces started, XFree86 3.1.1 behaves oddly;
	xdm displays the (solid) root window and the login window sans text!
	Switching back to a text mode vt shows some sort of corruption to
	video memory, with each column containing a double-vertical-bar
	pattern across the entire screen.  I use the aperture driver, which
	I suspect is related.

	Everything is working fine with the 19 Apr 1995 kernel that I have.
	(The only reason I'd like a more current kernel is because I
	misconfigured swap in the one that otherwise works :-( ).
	See above.