Subject: port-i386/625: Problems printing to parallel port lpt0 with NetBSD 1.0
To: None <>
From: None <>
List: netbsd-bugs
Date: 12/10/1994 06:35:11
>Number:         625
>Category:       port-i386
>Synopsis:       Data corruption when sending data to printer via lpt0
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    gnats-admin (GNATS administrator)
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Dec 10 06:35:04 1994
>Originator:     Martin Lubitz
 Martin Lubitz (NeXTmail welcome)
 Berlin - Germany >>>>>>> 2b || !2b; that is the question... <<<<<<<
>Release:        1.0
Machine: 80486/33 EISA, 4 MB RAM
         Standard (no-name) IO-Board (2S 1P 1G)

System: NetBSD 1.0 NetBSD 1.0 (LUSI1) #2: Sat Dec 10 01:11:01 CET 1994 i386

	When sending data to my printer (HP Laserjet 4) via the parallel
	port lpt0 (at 0x378, irq 7) it gets corrupted to a certain degree.
	The printer displays Error 22 which indicates a IO buffer overflow.
	It will continue to print but seems to lose some data.
	This happens mostly with graphics (large amount of data) or
	multi page documents.
	The problems seems to be uninfluenced by system load and/or
	network traffic.
	The same hardware configuration was working flawlessly with
	the lpa driver of NetBSD 0.9 which seems not to be included
	Send some data with lpr to the printer on the parallel port lpt0.
	My /etc/printcap:

#	@(#)printcap	5.3 (Berkeley) 6/30/90

lp|local line printer (Standard):\

hplj4|Printer for PC clients:\