Subject: Problem with NCR SCSI
To: None <>
From: D. Gerasimatos <dim@CSUA.Berkeley.EDU>
List: netbsd-bugs
Date: 09/20/1994 00:33:22
I am attempting to install NetBSD 1.0 using an ASUS SP3G (utilizing the
onboard NCR 53c810 SCSI controller) and a single internal Quantum Empire
1080S disk (the only SCSI device). I have the cache configured to
write-through and have the BIOS set up correctly. The controller uses
IRQ 9 and pci slot 4, and the disk is detected by the NCR SCSI BIOS upon 
startup. However, NetBSD cannot seem to find the disk... a transcript of
the floppy-kernel boot follows (where ellipsis denote information I left
out intentionally, because it wasn't really relevant imho). If someone
can give me any help or ideas as to what is going wrong, I'll much
appreciate it.     

Boots off kernel...

Insert install disk...

(lots of stuff that goes by too quickly, and is probably irrelevant)

 pc0 at isa0 port ... irq 1 ...
com0 at isa0 port ... irq 4 ...
com1 at isa0 port ... irq 3 ...
com2 at isa0 port ... irq 5 ...
lpt0 at isa0 port ... irq 7 ...
fdc0 at isa0 port .... irq drq 2
 fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
pci0 at isa0 port 0x0-0x665: configuration mode 2
pci0 bus 0 device 0: identifier 04838086 class 00000004 not configured
ncr0 at pci0 bus 0 device 1
pci_map_mem: memory mapped at c000000_c0000fff
pci_map_int: pin A mapped to irq 9
ncr0: restart (scsi reset)
ncr0 scanning for targets 0..6 ($Revision: 1.1 $0$)
scsibus4 at ncr0
pci0 bus0 device 2: identifier 04848086 class 00000003 not configured
pci0 bus0 device 5: identifier 00a81013 class 03000026 not configured
ie0: unknown AT&T board type code 15
nex0 at isa0 port oxf0-0xff: using exception 16
biomask 240 netmask 3a ttymask 3a
changing root device to fd0a
WARNING: no swap space on device

Then some error about a missing file in /etc and then the prompt to 
start sh.