Subject: Need help with my PS/2 busmouse
To: None <>
From: Piet Tutelaers <>
List: netbsd-bugs
Date: 01/06/1994 17:17:07
Hello NetBSD-ers,

I hope that somebody can explain to me what I am doing wrong to get my PS/2
busmouse installed on my DECpc (minitower type 450d2 MT) under XFree86-2.0
on NetBSD-0.9.

In the manual page of pms(4) there is a line which I have included in
my GENERICAHA configuration file (the manual says IO_BMS0 but this is
not defined in isa.h so I toke the existing IO_BMS1):
 device pms0 at isa? port "IO_BMS1" tty irq 5 vector pmsintr

Of course I have rebuild a new kernel and installed it over the old
one.  When I start X (startx script from XFree86-2.0) then I get the
nice X screen but my mouse is not recognized. At home where I use a
Logitech mouse connected to a serial COM port I have no problems.
Because my ethernet card is on irq 5 I have also tried irq 12 (that was
reported by msd -- MicroSoft Diagnostics --) but with the same result.

I also have other problems for which I would appreciate some help:
 - the time 
   I have defined the timezone as `-1 dst 4' as we normally do on our other
   UNIX boxes. But this gives a big difference with the real time here.
   What do I need in the Netherlands?

 - mtools can't recognize 720kb 3.5inch floppies on my 486clone at home
   I have installed mtools-2.07 with the patches I found on to
   handle this low denisity floppy format. But if I do an `mdir' I get some
   complains (hard errors) but no directory information. The 1.44MB format
   works nice.

 - mtools crashes NetBSD on the DECpc
   Perhaps this has to do with the fact that the floppy drive on the DECpc
   is a 2.88MB drive? Does anybody know how to get around?

I have used the most recent `Frequently Asked Questions for 386BSD,
NetBSD and FreeBSD, and other BNR/2 derived OS's' from Dave Burgess I
could find on comp.answers. Is that the ultimate documentation for