Subject: NetBSD Security Advisory 2000-013
To: None <>
From: None <>
List: netbsd-announce
Date: 10/26/2000 19:31:12

                 NetBSD Security Advisory 2000-013

Topic:		cfengine contains format string vulnerabilities
Version:	any before 1.5.3nb3 
Severity:	possible remote root compromise.


Note: The cfengine package is not part of the base NetBSD distribution,
and is not installed by default.  It is part of the NetBSD package
collection, which contains a large number of third-party applications
in ready-to-install format.

NetBSD makes no claim about the suitability or security of these
third-party applications; however, when we become aware of severe
security holes in commonly used packages, we may release advisories
such as this one.

The cfd daemon in GNU CFEngine contains several format string vulnerabilities
in syslog() calls.  This could permit remote hosts to inject the network
daemon with a message causing a segmentation fault.  As cfd is almost
always run as root due to its nature (centralized configuration management),
this could lead to a root compromise.

This advisory was based on a message from to BUGTRAQ from Pekka Savola

Solutions and Workarounds

Versions of cfengine older than version 1.5.3nb2 could be vulnerable.  To
find out the version of cfengine installed on your NetBSD system, you can use

	# pkg_info -e cfengine-\*

If cfengine is not installed on your system, no output will be generated,
and your system is not vulnerable to this problem.

If you have a version older than, or including, 1.5.3nb2, you should
upgrade to version 1.5.3nb3 (or newer) of cfengine.  A corrected
version has been part of the NetBSD packages collection since 2nd
October 2000.

If a vulnerable version of cfengine is installed, then you should
immediately remove the vulnerability by deleting the package.  As
root, type:

	# pkg_delete -v cfengine-\*

If you continue to need cfengine, you should install a new version of
the package.

There are precompiled binary packages of cfengine for some NetBSD ports
available from:

If no precompiled binary is available for your platform, you can build
your own from source.  First, make sure that you have a version of the
pkgsrc hierarchy from 2nd October 2000 or later.  (See for ways to obtain NetBSD, and
pkgsrc, its packages collection.)

You can then install the new version of the package:

	cd pkgsrc/sysutils/cfengine; make clean; make install

For more information on how to rebuild a package from source for your
architecture, see

Revision History

	20001024	revised prior to publication.

More Information

Information about NetBSD and NetBSD security can be found at
http://www.NetBSD.ORG/ and http://www.NetBSD.ORG/Security/.

Copyright 2000, The NetBSD Foundation, Inc.  All Rights Reserved.

$NetBSD: NetBSD-SA2000-013.txt,v 1.4 2000/10/24 14:39:40 agc Exp $

Version: 2.6.3ia
Charset: noconv