Subject: NetBSD on Performa 550
To: None <macbsd-general@NetBSD.ORG>
From: Kevin Crandall <>
List: macbsd-general
Date: 02/05/1996 08:32:22
Dear folks,

I recently purchased the NetBSD CD from InfoMagic, fully understanding that
NetBSD might not run on my Macintosh Performa 550.  I had seen vague
references on the internet to NetBSD running on a 550, but it seemed like a
long shot.  So, if you can lend any clues I would appreciate the help.

I'm running:
Mac Performa 550
162 MB internal Sony HD
121 MB external Micronet HD
System 7.5.1

On my internal HD, I created a 100MB A/UX root/usr partition, a 15 MB A/UX
swap partition, and the rest is a MacOS partition which contains a System
Folder and the NetBSD setup applications (Mkfs, Installer, Booter).

I am not running RamDoubler.

I ran Mkfs on the root/usr partition.

I ran the Installer and installed: Base11, NetBSD11, Etc11.  I also created
my devices.

I rebooted MacOS  with extensions off, and with the external HD turned off.

I then ran the Booter, chose the correct SCSI ID#, and was pleased when the
booter ran through it's business, prompted me for the boot, and seemed to
make it partway through a NetBSD boot!

Here's where things seemed to go funky, where it dropped into the debugger...

[lots of stuff about bootstrapping, moving ROMBase, video address, etc]

NetBSD 1.1 (Generic) #47: Wed Nov 22  19:17:19 PST 1995
                root2@ wormhole:/disk2/src/syc/arch/mac68k/compile/GENERIC
Apple Macintosh Performa 550 (68030)
real mem = 5242880
avail mem = 2543616
using 89 buffers containing 364544 bytes of memory
mrg: 'Mac Classic II Roms' rom glue, tracing off, debug off, silent traps
adb: bus subsystem
Got following HwCfgFlags: 0xec00,0x      773f,   0x1b404926,0x      0
mrg: setup egret:
unknown OS trap  0xa247, no trap address available
panic: mrg aline super ()
Stopped at                      _Debugger +0x6:     unlk        a6

And there it hung up tight.  there is no sign of any "grey bars".   Should I
just give up?  When it says unknown OS trap, is this because I'm running
7.5.1 - maybe I should drop back to 7.5

Also, 32 bit has been turned on in control panel - it probably should be
turned off.

Thanks for your time and consideration, and please forgive me for asking
questions that I'm sure have already been addressed in previous discussions.

- Kevin Crandall