Subject: Problem with Mkfs on Syquest
To: None <port-mac68k@NetBSD.ORG, macbsd-general@NetBSD.ORG>
From: Patty Nunez <>
List: macbsd-general
Date: 12/01/1995 20:03:02
I have tried unsuccesively now to set up a UNIX file system on my Syquest
EQ135 drive.  I have used Alliance Power Systems formatting/partitioning
software and set up a 90 MB root and a 30 MB swap space on the Drive.
Everything went fine and I even put a little Mac system folder on there and
I can boot from it and play with the little Mac space so I now that things
are at least a little bit fine as far as the setup goes.

When I run mkfs on the drive, however, I click on the SCSI ID of my drive
and I get ...

modesense page4(0)
Error on SCSI select(), #2
get - device info returned 2
Partition read, SCSIID=0
Error on SCSISelect(),#2

On a hunch I went ahaead and changed the SCSI ID to 2 (Originally it was 4
and I got the exact same message).  I also allocated more memory to mkfs to
no avail.  As you can see I am clutching at straws now :)

I've looked at the Syquest web pages and the FAQ on howto set up on a
Syquest Drive but neither of those source leads me anywhere.

I know that MacBSD will work on my internal HD becuase I had a 1.0/current
mixture running on it no problem.  However, in anticipation of 1.1 I
reformatted teh drive and wanted to use it as a regular Mac Dive and put
the BSD on the external drive.

I know Kevin used a patched version of Apple HD setup to partition his
Syquest EZ135, but my guess is that he is running Mac OS 7.5 and added a
patch to the setup program that, luckily, allowed it to recognize the
Syquest Drive.  I am running 7.0.1 and Apples HD Setup there won't let me
see the drive.  I looked at apple's support pages and downloaded a new HD
Setup and the patch to the app from Info-Mac, but the patch told me that
the version I downloaded of Apple HD setup was more vercent than the patch
was for and the patch was already applied.IT failed to recognize my drive,

That should be irrelevant,however, because I had formatted and partitioned
my internal Mac drive earlier this year with APS's tool and had no problems
with mkfs.

Anybody have any clues.  I have now grabbed the source for mkfs and will
look into that a little closer, but I am getting over my head right now as
far as understanding what is going on.

Which is why I wanted MacBSD in the first place anyways, soooo.... :)

Patrick Nunez