Subject: IIvx/general lack of success
To: None <macbsd-general@NetBSD.ORG>
From: None <>
List: macbsd-general
Date: 07/28/1995 23:55:41
I'm not sure if this is a IIvx problem or just general "I don't know what
I'm doing" since this is my first attempt at getting NetBSD to run.

	internal video (14" monitor)
	internal 80 MB SCSI at ID 0
	external 170 MB SCSI at ID 1

I'm trying to just boot the kernel netbsd.IIvx7.  I'm using the Booter 1.6.
I have gray bars turned on, single-user mode, 12MB RAM & auto-size RAM.
Extensions off, 32 bit mode, b&w graphics (tried in both "colors" and 

The results:
[ preserving 86149 bytes of netbsd symbol table ]
System RAM: 12582912 bytes in 3072 pages.
     Low = 0x0, high = 0xc00000
Non-System RAM (nubus, etc.):
     Log = 0xf9000000, Phys = 0xf9000000, Len = 0x6000000 (100663296d)
get_mapping(): IIvx kludge.  Does it never end?
               Forcing VRAM size to a conservative 512K.
  IIvx-like internal video at addr 0x60b00000 (phys 0x60b00000), len 0x80000.
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.

NetBSD 1.0A (GENERIC) #62: Thu Jul  6 08:41:03 EDT 1995
Apple Macintosh IIvx  (68030)
real mem = 12582912
avail mem = 9371648
using 179 buffers containing 733184 bytes of memory
mrg: 'mac IIsi class ROMs' rom glue, tracing off, debug off, silent traps
adb: bus subsystem
adb: mapped device (5) at 2
adb: 100 dpi mouse at 3
mainbus0 (root)
ite0 at mainbus0 (minimal console)
adb0 at mainbus0 (ADB event device)
ser0 at mainbus0
ser1 at mainbus0

The last line of text is always cut off half-way down (i.e. only the upper
half is visible).  It is slightly variable how many characters of the last
line get printed (it often stops at the first 'm').

I feel that I must have come at least close to exhausting all possible 
combinations of settings, with little variance in the end result (it hung once
on the ser0 line).

I'd appreciate some help in getting this resolved since others have had 
success - it must be possible.


P.S. I tried a newer kernel than the IIvx7 and the behaviour was the same.
 Keith MacDonald                                      Computer Engineering                            Concordia University      Montreal, QC, Canada