Subject: Troubles with IIsi
To: None <macbsd-general@NetBSD.ORG>
From: Martin Jerabek <>
List: macbsd-general
Date: 06/27/1995 14:57:58

I installed NetBSD 1.0 on my Mac a few days ago but I have problems to boot
it successfully. I have the patched NetBSD-kernel (Nov 3, 1994, size 623480
bytes) just as the IIsi-HOWTO says and I followed the rules therein but I
still get an vm_fault (panic: MMU fault) during the execution of /etc/rc or
shortly after logging in. It is perfectly reproducable so if someone wants
the register dump I can mail it. If I allocate less memory in the booter (eg.
4MB instead of 16 or 17) I reach the point where I can log in as root but
after one or two commands the system drops into what I believe is the kernel
debugger. The current pid is that of the shell if it crashes during /etc/rc
or that of the command I tried to execute.

I edited /etc/rc but the hangup is independent of the command during which it
occurs. I also removed swapon -a but it didn't have any effect. It is obvious
that it has something to do with the amount of memory. I normally use the
SuperMac Spectrum 8.24 PDQ graphics board but even if I remove it the machine
still crashes. I have 17MB RAM and as far as I can tell it is identified
correctly (Low=0x0, high=0x100000; Low=0x4000000, high=0x5000000, real
mem=17821696, avail mem=14569472) because I don't use the internal video (the
boot screen says: "get_mapping(): No internal video"). I also tried different
video modes, both with the internal video and the SuperMac card: no effect.
Boot Mac without extensions: No effect.

My equipment:

IIsi, 17MB RAM, System 7.5.1 US, Apple NuBus adapter with 68882, SuperMac
Spectrum 8.24 PDQ v1.37, 13" Apple RGB monitor (640x480), NetBSD partition >
200MB, swap partition 32MB. I use only the serial console (with serial boot
echo), so the video card shouldn't be important. I would really like to use
NetBSD so that I can finally dump my Linux PC. I *know* that someone uses it
on his/her IIsi so what shall I do? Please help! I'm sure the same questions
were asked before so if they were answered just point me to the right file in
the macbsd-general mailing list archive so I can fetch it.


PS: Some other questions: When I use the internal video, the "real mem=" line
is completly wrong (several dozens of MBs), although avail mem and low and
high look sane. Why?
During boot it says: Desktop bus initializing... adb_init(): Timed out!!!
It also says: File system date earlier than 1975 although the clock on my
IIsi is set correctly. Why?