Subject: Compiling xlock
To: None <"O=bhp; OU1=bhpmelint; DDA.TYPE=RFC-822; DDA.VALUE=macbsd-general">
From: Ripke Paul PR <>
List: macbsd-general
Date: 06/20/1995 15:27:37

I am sorry for this disgustingly formatted mail, but I am at work, and this
is sent from MSMail :(  which is why this is also why it is going to the list
- I don't know your address.

I managed to get xlock working properly by:

changing cuserid(??) to getlogin(??) in xlock.c (??). Sorry for all the
unknowns, but my system isn't networked and about 30 km away, and my memory
is running heavily into swap ;)
A "grep cuser *.c" should find the relevent bits, and a "man cuserid" tells
you the valid alternatives.

Setting xlock to run setuid root. This allows it to access the secure
password DB.

I don't know if this is the right way to do it, but it works for me :)

Paul Ripke

Don't you just love MSMail?? ;)
From: O=bhp; OU1=bhpmelint; DDA.TYPE=RFC-822;
DDA.VALUE=owner-macbsd-general(a)NetBSD.ORG on Tue, 20 Jun 1995 3:21 AM
Subject: Re: Processes auto-nicing to 4
To: O=bhp; OU1=bhpmelint; DDA.TYPE=RFC-822;
DDA.VALUE=macbsd-general(a)NetBSD.ORG; Ripke Paul PR

I haven't noticed this problem when I was compiling xlock for MacBSD, but 
I do have another problem with xlock.  I cannot seem to get the password 
feature to work correctly.  Only accounts without passwords seem to be 
able to unlock the screen.  Has anyone else tried this?  If you've solved 
it, please mail me.