Subject: Re: Problems booting a IIcx
To: Olof Johansson <>
From: Allen Briggs <>
List: macbsd-general
Date: 06/08/1995 08:58:06
> I've tried removing the ethernet card, and nothing changes. The 051695 
> kernel didn't boot at all (last message i got was "enabling interrupts".

Are you on a localtalk network?  The boot sequence is sensitive to
an active localtalk connection.  I just made a change that might
help this.

If that's not it, my next guess is that something is running a lot
of interrupts and we're not set up to handle them correctly, yet.
This does need to be fixed, but that won't help you now.

> It displays 1 color no matter if I have 1 or 4 bitplanes configured.
> My screen isn't 640x480 either, it's an A4 monitor (15", I don't know the 
> resolution of it). And yes, I've tried booting your kernels with a 
> 640x480 monitor.

This is because the NuBUS probe routines don't know the currently active
video configuration and a number of cards have quite a few to choose
from, so it chooses the default (sRsrcID 0x80) for that info.  This is
also "in the works."  Do you have access to a simpler video card and
monitor to try with that?


Allen Briggs - end killing - ** MacBSD == NetBSD/mac68k **