Subject: Problems booting a IIcx
To: None <macbsd-general@NetBSD.ORG>
From: Olof Johansson <>
List: macbsd-general
Date: 06/07/1995 20:53:55

I've been trying to get NetBSD/mac68k to work on a IIcx.
The NetBSD-1.0 kernel boots, but the -current kernels from cray-ymp 
It freezes right after detecting grf0.
I don't know what model my graphics card is, it's an Apple nubus card 
with two 72-pin SIMMs on it and a 15-pin D-SUB (which doesn't say too 
much). It's got "(c) 1989-90 Apple Computer" and "Macintosh Display Card" 
printed on the board.

This is the boot messages i get (and the backtrace from the kernel debugger):
This is the NFS-kernel from cray-ymp. The other ones behaved the same.

[ preserving 82481 bytes of netbsd symbol table ]
DEBUG: Console initialized.
Low = 0x0, high = 0x800000
8388608 bytes available (2048 pages)
Log = 0xf9000000, Phys = 0xf9000000, Len = 0x6000000 (100663296)
get_mapping(): no internal video.
  Video address = 0xf9000080
  Weird mapping starts at 0x0
  Length = 0x0 (0) bytes
DEBUG: 68030 - MMU mapping parsed.
DEBUG: Got memory size as passed from Booter.
DEBUG: preparing new MMU context.
DEBUG: clearing TT registers...
DEBUG: about to set MMU control (hold your breath).
DEBUG: yay!  MMU enabled with new mapping.
DEBUG: MMU flushed.
DEBUG: calling pmap_bootstrap() ...
DEBUG: done.
DEBUG: invalidating TLB.
DEBUG: activating cache(s).
DEBUG: calling setmachdep().
DEBUG: done.
DEBUG: enabling interrupts.
DEBUG: done.
DEBUG: away we go!  (calling _main)
Copyright (c) 1982, 1986, 1989, 1991, 1993
        The Regents of the University of California.  All rights reserved.
NetBSD 1.0A (NFS) #1: Wed Apr  5 00:51:51 PDT 1995
Apple Macintosh IIcx  (68030)
real mem = 8384512
avail mem = 5525504
using 127 buffers containing 520192 bytes of memory
mrg: 'Mac II class ROMs' rom glue, tracing off, debug off, silent traps
adb: bus subsystem
adb: mapped device (5) at 2
adb: 100 dpi mouse at 3
mainbus0 (root)
fpu0 at mainbus0 (mc68881)
adb0 at mainbus0 (ADB event device)
nubus0 at mainbus0
grf0 at nubus0PC is 0x953b6.
Stopped at      _Debugger+0x6:  unlk    a6
db> trace
_Debugger(8f5aa,953b6,fffffc78,16e6,50f0207e) + 6
_nmihand(50f0207e,d,1,0,0) + 28
_lev7intr(1) + 12
_via2_intr(fffffca4) + 50
_add_nubus_intr(f9000000,81e6c,0,b2606,fffffd28) + 14
_macvideo_init(aa564,b25f6,7f492,aa564,c12f00) + 8c
_grfinit(b25f6,0) + 4a
_grfprobe(b25f6,0,fffffdc4,15274,c12f40) + 32
_grfprobe(c12f40,c12f00,b25f6,b25f6,c12f40) + e2
_config_attach(c12f40,a607e,b25f6,7f492,0) + de
_config_found(c12f40,b25f6,7f492) + 2e
_nubus_addr_to_slot(c04000,c12f40,fffffe88,fffffe88,c04000) + 19c
_config_attach(c04000,a5fee,fffffe88,8cf12,0) + de
_config_found(c04000,fffffe88,8cf12) + 2e
_matchbyname(0,c04000,8cea4,8cea4,8cea4) + 120
_config_attach(0,a5fd6,8cea4,0,124) + de
_config_rootfound(8cea4,8cea4) + 3a
_configure(8e5cf,7f,7f000,8e5bf,545000) + 24
_cpu_startup(9f6bc,c,f2041,f4001,f9000080) + 4f2
_main(ffffffb0) + 38

Please help me, since I'd _love_ to get NetBSD working on this one.
I run FreeBSD on my PC, and it's great.

Have anyone tried having everything but the root and swap on local disk, 
and the rest over NFS? (It'd be The Solution for me, since I have a 40 Mb 
disk in the IIcx and plenty of disk in my PC).