Subject: IIci results w/ -current
To: None <macbsd-general@NetBSD.ORG>
From: Brian Gaeke <>
List: macbsd-general
Date: 05/29/1995 18:50:53
I've just gotten the tarballs from and the kernels from
puma and I've just gotten MacBSD to run on my IIci! I'm quite pleased,
although admittedly not everything is running smoothly. Here are the major
things that are bothering me:

1. Must cold boot between instantiations of MacBSD, otherwise it freezes
   after "ser0 at mainbus0" (right before "ser1 at mainbus0" and "nubus0 at
2. No support for my ethernet card!! :( It's a Farallon EtherMac II-TP (btw).
   Is this something that I should try to work on or is that part of the
   kernel already being worked over?
3. Still doesn't work with my video card (a SuperMac Spectrum 8*24 PDQ) -- but
   I didn't expect it to. The weird thing is that as it boots up it says
   'Weird mapping starts at 0x0, length 0x0.' and then it hangs at 
   "DEBUG: about to initialize MMU (hold your breath)" or something like that.
   I'm just concerned about that since it would seem that a mapping of zero
   length would certainly confuse the MMU, so the question becomes: why is it
   deciding on that weird mapping? Anyway, that problem's not really as
   important as the...
4. Random panics of the form: "panic: cpu_swapout: can't get here" then
   "stopped at _Debugger + 0xnnnn : unlk a6". I'm not entirely sure what is
   generating these. There are some things I do remember that made it happen:
   a. telnet localhost (i think this worked the next time I tried it)
   b. dt (only tried it once)
   c. shutdown (seemed to do it whenever it got to the 'reboot' program.)
5. MacBSD Install Utility 1.0 barfed on the tar.gz files that I had so I ended
   up untarring them on my Linux system, tarring them back up again using GNU
   tar, and using an older, non-gunzipping installer (which worked except
   that it didn't understand the links. GNU tar's -o option didn't work
   either, and poking around on a NetBSD-current source mirror didn't yield
   a tar program???) 

All in all, though, I'm happy that it finally boots on my computer. Here's my
configuration if you're interested:

Macintosh IIci (68030 w/ FPU), 8 MB RAM
Things on the SCSI bus:
   0. Quantum LP80S - internal 80 mb hard drive
   1. Syquest SQ555 - 44mb cartridge, root 37MB and swap 5MB and macos 1MB
   2. Syquest SQ5110 - a broken 88mb cartridge drive
   3. nothing
   4. Fujitsu M2266S-512 - external 1.0GB hard drive, 5 macos partitions
   5. Seagate ST296N - external 80 mb drive, 100% ufs on /a
   6. nothing
   7. the IIci

Things in the NuBus slots, according to "Slots":
   0. (pseudo-slot) Macintosh II Built-In Video
   C. SuperMac Technology VideoSpigot 1.0
   D. SuperMac Technology Spectrum 8*24 PDQ v1.60
   E. Farallon EtherMac II-TP

The kernel I was using is named 'netbsd.050695' but it's not anywhere I can
see. I vaguely remember that the netbsd.051695 kernel on puma didn't work.
If you want a copy of the kernel I'm using, try grabbing:
<URL:>  To whoever compiled it,
thank you! :)

I plan to try compiling a -current kernel soon; I'll post results later.
If anyone has any insights into my troubles, please post!! Thanks!

Happily macbsd'ing, 

Brian Gaeke, The Dimensional Gate Company    Internet E-Mail: <>
DGate.ORG system adminstrator / PGP 2.6.2 public key available via finger