Subject: Getting X to work on a IIsi
To: None <macbsd-general@NetBSD.ORG>
From: John W. Price <pricej@CEBAF.GOV>
List: macbsd-general
Date: 05/16/1995 08:56:15
Now that I have a working kernel (thanks guys!!!), I'm trying to get the X
distribution to work. So far, no luck. But it seems that either I'm doing
something wrong, or the README.X11R6 file is wrong. Probably the former...

As explained in the instructions, I copied the X.11Mar95.tgz file into
/usr, then typed

tar xzvpf X.11Mar95.tgz
set path=($path /usr/X11R6)

and got the response "command not found". On a lark, I typed

set path=($path /usr/X11R6/bin)

and it then worked. At least, it found the command. Shortly thereafter, I
got the message: xinit: No such file or directory

I poked around the imake files for a while, and then, again on a lark,
copied this file it was looking for into /usr/lib. Then, it got a bit
farther, and eventually asked for another file -- I also had
to copy over and

Anyway, after copying all these files, I got the following error message,
which strikes me as similar to the one Daniel Risacher encountered last
week or so when he tried to get this to work: warning: minor version >=1 expected, using it anyway Undefined symbol "__sys_errlist" in X:X

[...pause for about 10 seconds...]

giving up.
xinit:  Interrupted system call (errno 4): unable to connect to X server
xinit:  No such process (errno 3): Server error.

Any hints on how to proceed from here?  Furthermore, what exactly am I
doing wrong that prevents me from running (even if it doesn't work) without
copying files around?

            John Price  ***  ***  ***  ***
            Where there is no solution, there is no problem.