Subject: big disk blues
To: None <macbsd-general@NetBSD.ORG>
From: None <>
List: macbsd-general
Date: 05/15/1995 13:44:34
Here's a report of installing NetBSD on a large (4 GB) hard 
drive.  I worked out most of the problems, but I have a few 

A couple months ago, I partitioned my lowly 234 MB hard 
drive on my Mac IIvx.  Ever since then, I have been running 
NetBSD (via serial line) and getting very frustrated about 
running out of space, both on the Mac and UNIX side of 
things.  So I've been mulling over buying another hard 
drive.  On Saturday I took the plunge and purchased a 4 GB 
Quantum Grand Prix.  I hurried home to install NetBSD.  
Formatting the disk took over two and a half hours.  I 
decided to go to sleep and run diagnostics over night.  On 
Sunday morning, I partitioned the disk with Silverlining and 
ran mkfs (from the Mac OS) on the root&usr filesystem.  At 
the end, I got an error which was something like:

cg 0: bad magic number

I decided to try to run newfs (from the UNIX OS), since my 
small hard drive already had NetBSD installed.  I noticed 
that the sectors/track was different than it was for mkfs, 
and I didn't get any errors.  Newfs said it was 103, and 
mkfs said it was 118, which agrees with Silverlining and the 
manufacturer's data.  I tried using disklabel to get newfs 
to think it was 118.  Having no success at that, I finally 
decided to accept that the disk had 103 sectors/track.  A 
consequence of this is that there are fewer sectors/cyl, and 
less total available space on the disk.  Since the total 
number of cylinders did not change, the output of disklabel 
showed that my HFS partition extended past the last 
cylinder.  Just to play it safe, I used Silverlining to 
reduce the size of the HFS partition, leaving some unused 
space at the end of the disk.

To summarize, there is a discrepancy between mkfs and newfs 
regarding sectors/track.  While the mkfs value agrees with 
both Silverlining and the manufacturer's data, the newfs 
value allows one to successfully install the filesystem.  It 
is a good thing that I already had NetBSD working on my 
small disk, or I never would have figured this out.

So now that I had my root&usr filesystem on the big disk, I 
decided to install NetBSD.  I ran the install utility and 
selected the SCSI # and I got an error that was something 

bad dir: ino 2

and the install program terminated.  Just to make sure that 
the filesystem wasn't corrupt, I booted single user off the 
small disk and ran fsck on the big disk -- no problem.

To summarize, I am unable to use the install utility to 
install onto the big disk root&usr partition.

Any ideas why this is so?

I resigned myself to the fact that I would not be able to 
install directly onto the big disk.  I decided to try the 
following fstab configuration:

/dev/sd0a	/	ufs	rw 1 1
/dev/sd1b	none	swap	sw 0 0
/dev/sd1g	/usr	ufs	rw 1 1

I re-partitioned the big disk with Silverlining, creating a 
swap and a usr partition.  I had read the documentation on 
how to set up a split usr, and I thought that I would be 
able to install into /usr by having a /usr partition and the 
above fstab.  Unfortunately, when I did an installation, the 
data went into a directory on the root filesystem.  I was 
able to get the data into the correct filesystem, by booting 
single user, and moving the data out of the /usr directory, 
then booting multi user, and copying the data to the /usr 

Did I do something wrong, or is this a limitation of the 
installation utility?

Things seem to be working OK, now.  One final thing.  When I 
boot, the system complains:

WARNING: primary swap device not configured

I realize this is because I have the swap space on sd1b 
instead of on sd0b.  My question is, will this adversely 
affect performance?