Subject: NetBSD on a MacII
To: None <macbsd-general@NetBSD.ORG>
From: Brad Salai <>
List: macbsd-general
Date: 04/07/1995 09:43:25
I have been trying to get netBSD running on a MacII for a few weeks now
with no luck.

The machine is a Mac II, with a PMMU, 68882 FPU, 20 meg RAM, NetBSD
installed on an external 210 MB drive, one AUX root&usr partition and a 40
Meg swap partition.

The kernal seems to load ok, it does report errors which seem to relate to
my internal scsi hard drive, but gets to the point of saying something very
much like press return to start sh.

If I press return it warns me about running with dot in PATH and then goes
to the beginning of a new line, no prompt, and unresponsive to anything
other than a hardware reset.

If I do /bin/csh, instead of return, I get a # prompt on a new line, but
almost anything I try leads to the same new line, no prompt and no
response. Sometimes I get dumped into a debugger, but never get anything
I have tried /etc/ls and a few other things, but same result each time.

Any ideas? I'm not terminally discouraged, just frustrated


Stephen B. "Brad" Salai             
Cumpston & Shaw                               Office (716) 325-5553
Two State Street                              Home   (716) 377-4624
Rochester, NY 14614