Subject: violent cd rom tendancies... (long)
To: macbsd general list <macbsd-general@NetBSD.ORG>
From: Erik Vogan <>
List: macbsd-general
Date: 03/27/1995 22:57:42
Alright ...

	Now I'm REALLY pissed!!!!  I just lost my file system for the 
second time tonight, and I'm looking for some helpful advice.
	Symptom:  I try to mount a 9660 CD rom and all mounted file 
		systems die (badly too).

	So this surfaced sometime around january, when I tried the first 
time.  My system was acting sorta flaky, so I shrugged it off.  Tonight I 
decided I NEEDED to mount a cd rom (or at least be able to later on), so, 
in a rare fit of total paranoia (just because I'm paranoid doesn't mean 
that they aren't out to get me!) I tarred the entire contents of my root 
partition and unmounted everything else.

	I then created the appropriate cdrom drivers in /dev with
MAKEDEV cd*  where * was originally 0, then later 1 and 4.  The first 
time through I issued the command:

	mount_cd9660 -o rdonly /dev/cd0a /cdrom

in single user mode.  My system has an internal 730 MB quantum HD (SCSI 
ID 0, duh!), an external NEC CDR 73 (SCSI ID 4), and an external 340 MB 
quantum HD (SCSI ID 6).  The ufs is on the 730, and has given me no 
trouble in the last month (through some heavy use - kernel and X app 
compiles and the like).

	The system responded with a light coming up on the front CD rom 
drive panel, followed by a whirring of the disk, and then the system sat 
awaiting my command.  I cd'ed to the /cdrom directory and did an ls.  The 
system responded with:

	.: not a directory.

	I tried cd .., to no avail.  A short time later the system fell 
into the bottomless depths of the kernel debugger, never to be heard from 
again.  A quick reboot into the MacOS and a look with the installer told 
me that my paranoia was justified!!  The root filesystem was 
non-existant.  I mkfs'ed, installed the kernel and made the devices, 
booted into unix, copied my tarred root back to life, and rebooted (unix 
begets macos begets unix begets ...).  This time I tried cd1a, cd1d, cd4a 
and cd4d (because the installer utility calls my cdrom sd1, and because 
my cdrom drive is scsi id 4, respectively).  I know, wishful thinking!!  
This didn't work.  I got the "device undefined error".  So I tried the ill 

	mount_cd9660 -o rdonly /dev/cd0d /cdrom

after which the system again died quite painfully.

	Has anyone mounted a cdrom, and if so, what kind of drive do you 
have ?  Does anyone else have an NEC cdrom drive, or do you know where I 
can get tech specs on a circa 1990 NEC drive ?  Does anyone know what 42 
means ?  Can anyone tell me what the difference between cdxa and cdxd ?

	Other noteworthy tidbits: running an unmodified (at the moment) 
1.0B (you remember, the 1.0 release ??) kernel.  Machine is a IIx, 8 MB 
RAM, mode 42 installed and running.  32 bit addressing on.  blah, blah.

	Obi wan, you are our last, best hope.  Please help us.