Subject: Re: X doesn't want to start
To: None <tres@rap.ucar.EDU>
From: Ken Nakata <>
List: macbsd-general
Date: 03/13/1995 13:23:24
   From: tres@rap.ucar.EDU (Tres Hofmeister)
   Date: Mon, 13 Mar 1995 10:34:57 -0700 (MST)

   Ken Nakata writes:
   : I downloaded Allen's new X package, and tried with the SE/30 internal
   : video, but when I try to run xinit (or xmkmf, the other program I
   : tried), prints the following error message:
   : warning: minor version >= 1 expected, using it anyway
   : Undefined symbol "__sys_errlist" in X:X

	   I had the same problem, so I got the most recent (?) shared
   libraries I could find by installing the base.tar.gz stuff from  That took care of the problem.

Thanks Tres.  I'll give it a try.

However, I searched for __sys_errlist a little further and found
another anomaly; __sys_errlist is *defined* in Xmacbsd and some other
binaries, rather than referenced by them.  Could anyone explain what's
going on?

	   The one other thing I found that I needed to do was to make
   sure the dynamic linker knew where the X11R6 shared libraries resided.
   I stuck the line:

	   ldconfig /usr/X11R6/lib

Yes, but I ln'ed /usr/X11R6/lib/* into /usr/lib, so it shouldn't be a
problem (it makes me feel better if I have them in /usr/lib ;-).

Thanks again, Tres.