Subject: Re: X doesn't want to start
To: Ken Nakata <>
From: Tres Hofmeister <tres@rap.ucar.EDU>
List: macbsd-general
Date: 03/13/1995 10:34:57
Ken Nakata writes:
: I downloaded Allen's new X package, and tried with the SE/30 internal
: video, but when I try to run xinit (or xmkmf, the other program I
: tried), prints the following error message:
: warning: minor version >= 1 expected, using it anyway
: Undefined symbol "__sys_errlist" in X:X

	I had the same problem, so I got the most recent (?) shared
libraries I could find by installing the base.tar.gz stuff from  That took care of the problem.

	The one other thing I found that I needed to do was to make
sure the dynamic linker knew where the X11R6 shared libraries resided.
I stuck the line:

	ldconfig /usr/X11R6/lib the bottom of /etc/rc.local.  You can also set the
environment variable LD_LIBRARY_PATH to the directory instead, if you
prefer.  Just like SunOS 4.1.x...

	Works like a charm.  And now I have a little free disk space
again!  Thanks, Allen!

Tres Hofmeister                       Research Applications Program         National Center for Atmospheric Research
=-=  "If we knew what we were doing, it wouldn't be research!"  =-=