Subject: Re: fsck and others die with Floating Point exception
To: None <>
From: Bill Studenmund <>
List: macbsd-general
Date: 03/07/1995 22:41:38
[Various large partition problems deleted]
> I have found similar problems. I have a 1Gb IBM Spitfire drive as an internal
> hard disk. I have given NetBSD a 200Mb partition on that without problems.
> I would really like to give NetBSD my whole external 1Gb Seagate ST11200N,
> but I cannot get this to work. I partition using APS, mkfs, and install as per
> normal, but when I try to boot from this drive fsck comes up with BAD
> SUPER BLOCK errors, followed by the floating point exception described by others.
> I have tried various partitioning schemes, and it seems partially dependent on
> the order and size of the partitions. When I boot up from the 200Mb partition
> and look at the disklabel on the Seagate, the size of the disk is totally incorrect.
> It gives a very large negative number (so does cd0 incidentally).
> I have tried SpotOn formatting software as well, but there seems to be no difference.

Disclaimer: I don't have a running NetBSD system; I've got a IIsi.

The fact you get a negative number kinda indicates that some of the
size values are kept as signed 32-bit integers, and 2^32 is 4Gb. I
know that on our RS/6000, filesystems were limited to <2Gb under AIX 3.
Though I'd have expected the problem to not show up at 1.5 Gb.

Hope this helps! It's certainly good for me to know; I've been drooling about
getting MacBSD up, and thinking about getting extra drives for it. I'll
stick to the afordable 730 MB Quantum drives if I make the plunge.

Take care,