Subject: Re: fsck and others die with Floating Point exception
To: None <macbsd-general@NetBSD.ORG>
From: None <>
List: macbsd-general
Date: 03/07/1995 12:18:59
> At  9:28 PM 95.3.6 -0500, Andrew P. Herdman wrote:
> >I just installed the current netbsd1.0 code on my se/30 with 8 megs of ram
> >and 16 megs swap.  Unfortunatly when i first booted it it went a little
> >snakey and had to be reset.  The next time it came up it said corrupt
> >filesystem, run fsck manually.  When I go to run fsck i get 'Floating Point
> >Exception, Core dumped'.  Why?  Is it the kernal? Or did somthing just go
> >horribly wrong?
Yoshihisa Sugimoto ( replied:
> Now I have the same trouble, "Floating point exception".
> WITH THOSE IN FIRST ALTERNATE, Floating point exception (core dumped)".
> When I set 1880845 kbytes to sd1a, a floating point exception error occurs
> at fsck. I made partition with APS273 and mkfs showed no errors. Although I
> tried from the partition several times, the results were same. Now I'm using
> the disk with the error.
> When I divided less than 1 giga byets to sd1a, there were no error with fsck.
> The formatting procedures are all the same except the size of the partition
> divided to NetBSD.
> I also tried 1.5 giga bytes partition in vain. But I didn't try 1.1 giga 
> byte. So I am not sure that threshold is 1 giga bytes exactly.
> Yoshihisa Sugimoto /
> The First Department of Medicine  / The Medical Information Center 
> Shiga University of Medical Science, Ohtsu, Shiga, Japan

I have found similar problems. I have a 1Gb IBM Spitfire drive as an internal
hard disk. I have given NetBSD a 200Mb partition on that without problems.
I would really like to give NetBSD my whole external 1Gb Seagate ST11200N,
but I cannot get this to work. I partition using APS, mkfs, and install as per
normal, but when I try to boot from this drive fsck comes up with BAD
SUPER BLOCK errors, followed by the floating point exception described by others.

I have tried various partitioning schemes, and it seems partially dependent on
the order and size of the partitions. When I boot up from the 200Mb partition
and look at the disklabel on the Seagate, the size of the disk is totally incorrect.
It gives a very large negative number (so does cd0 incidentally).

I have tried SpotOn formatting software as well, but there seems to be no difference.

S. Claesen					e-mail:
Centre for Biological and Medical Systems	  Work: +44 (0)171 594 6223
The Sir Leon Bagrit Centre			  Home: +44 (0)171 232 0256
Imperial College				Mobile: +44 (0)1831 358078
London SW7 2AZ.