Subject: X issues: Amiga binaries, olwm, up- and down-arrow keys
To: None <macbsd-general@NetBSD.ORG>
From: David Myers <>
List: macbsd-general
Date: 02/20/1995 10:57:00
While trying to run the Amiga version of fvwm found at

I kept on getting an error message that looks like this (I'm paraphrasing): Unable to locate library libXpm

libXpm is a library (also found at the same ftp site) that fvwm requires.
The installation process for fvwm and xpm is automated, and apparently puts
things in the right places.  Even so, it still doesn't work -- and I even
tried putting in symbolic links to every conceivable place an X library
might reside.  fvwm simply cannot find the xpm library, and gives up.  So:
does the rule about binary compatibility with Amiga not apply for X

I'm also trying to get olwm & olvwm running -- this looks a little more
hopeful, as I have them in source form.  I'm not sure my imake and xmkmf
configuration information is all correct, however -- I still new at X and
don't really know what I'm doing.  I'll be sure to let this list know if I
get anything working.

One final thing: twm seems to eat the up and down arrow keys that I use for
emacs and tcsh.  Can I recover these somehow?  I assume that xmodmap will
do the trick, but if anyone's been through this before, a little guidance
would be great.

Thanks for the help.


David C. Myers