Subject: LOts of things about Mac BSD
To: None <macbsd-general@NetBSD.ORG>
From: Erik Bjorling <>
List: macbsd-general
Date: 12/29/1994 16:13:53
Hello all, I think you all might find this rant interesting and maybe even

SO I hears abouts this MacBSD thing...
It lets you run BSD Un*x on the mac.
Cool I says.
A friend gives me the cray site as a source.

So I FTP there and I find the directory.
I go to /pub/NetBSD_Mac and I find chaos.
I read the README. I look around.
I get both FAQs and Read them.
I find the 1.0 folder and read that README and the readme.late.
I grab the 1.0 distribution stuff.
I grab the latest kernal out of the new kernals folder(It's not new it is
from before the 1.0 release).
I install Mac BSD on an 80 meg Quantum partitioned with FWB Hard Disk
Toolkit after running MKFS.
Everything installs ok.
I get mode 32 and put it on my IIx with 8 Megs RAM and a Mac II Video Card
I run the booter. I set the options save, quit and boot.
The system boots. I get Grey bars (Blue if you have color on).
It hangs. I do this a couple of more times till it works.

After getting a prompt I go into sh and get the ADB bug after doing an ls.
But hey this wasnt that bad after 4 Hours.

So then I went seeking information. I checked out the mailing list archives.
I read about this and that and newer kernals and newer booters.
Nobody seems to post FTP sites though.
Mentions of the 'puma' site wasnt really helpful.
After going back to June I find a message with the 'puma' URL.
Also in the archives somewhere I find a couple of other URLs.
It would be nice if everyone posted the URL of whatever site they are
referring people too.
(Im going to have to redo all my hunting as my Hotlist got killed after a
crash and I lost all those sites I had found :-( )

Somewhere I see a message about Mac ROM Gluing and I somehow I find a site
reference somewhere. Turns out that it is in some odd directory (For a
current version that is) and it includes this Booter 1.6 that everyone is
looking for.

All in all this was very frustrating searching high and low for what was
current what was current for testing and where things were. Obviously this
stuff should all be in the FAQ, but since there are 2 of them and so many
things are unknown or unanswered, who knows. The FTP site should be more
organized if you want more people to get somewhere with this project.

SO now we get to what I have learned.
None of the kernals worked on my machine except the 071194.gz one found in
new kernals on the site.
I thought this was kind of funny. Here I grabbed this one first thinking it
was the latest and none of the current, semi-current, patched, fixed or
otherwise, kernals work.
All of them bomb out for some reason or another.
Most of them die with the ADB bug right after I get into the shell.
(Which makes me think it isnt the same ADB bug since there isnt any
scrolling, mousing or typing going on.) Oh I almost forgot I have the
original Apple Extended Keyboard and an original mouse, so it aint them.

DT never worked for me at all. Bus Error.
Screen 3.5.2 works fine except that the Termcap or something seems screwed
up for vt100 and vt220 and anything else. I think it is the console. But I
have no Idea what it is supposed to emulate. All I get with 'clear' or
while running screen are a bunch of control codes before every prompt and
bolded text in more or man.

So Ive got MacBSD running, what can I do with it?

The built-in console isnt usable, due to the control codes showing
up/not-working. No one has written a nice little explanation of setup for
using a serial terminal. I have no clue how the booter's serial terminal is
set up or what I should do if I turn it on. Someone who has done this
please jot down the process on both the mac and Un*x sides.
What about hooking up to a network? I have seen a little blurb on getting
slip going, but it made litle sense to me as the explanaition of the
commands was vague. PPP would be better. What about AppleTalk, TCP, Ether
and so one?
I know Ether is in the works, but what are the options until then?
It would be nice to be able to use this box for something, but since I have
no way to connect and be able to see what I am doing, I am stuck. I cant
even make an account for myself. vi is like hell in acsii.

For new people just getting into this I recommend reading all the archived
messages so you have an idea of what is going on before you go and try
running anything. At least until the FAQ(s) has been updated.

I think this project is a great idea and is looking really good so far but
it seems like there is a lot of confusion and disorganization about it.
1.0 behaves more like a beta.

oh, and if anyone wants a IIx I have about 10 from when I upgraded my company.
I would consider allowing the developers a chance to use one for testing if
there is interest. And I am willing to sell one at a reasonable price to
anyone that wants one.

Help me make this useful.