Subject: SE/30 Help Needed: dt Dumps Core
To: None <macbsd-general@NetBSD.ORG>
From: Tres Hofmeister <tres@rap.ucar.EDU>
List: macbsd-general
Date: 11/30/1994 01:10:00
	I've got NetBSD-1.0 installed on my SE/30.  The installation
went quite smoothly.  I'm experiencing what I assume is the
ADB/scrolling bug, and so have installed dt, version 1.0.  Whenever I
run it, though, it dumps core.  Here are some specifics:

Script started on Tue Nov 29 16:20:25 1994
myname# gdb dt.debug dt.debug.core
Core was generated by `dt.debug'.
Program terminated with signal 11, Segmentation fault.
#0  0x770c in grf_blankscreen (grf=0) at grf.c:633
633				*screenptr++ = 0;
(gdb) where
#0  0x770c in grf_blankscreen (grf=0) at grf.c:633
#1  0x669c in grf_init (fontname=0x63eb "large") at grf.c:192
#2  0x2f52 in main (argc=1, argv=0xffffcb90) at main.c:282
(gdb) list
628		while(rowcnt--)
629		{
630			screenptr = rowptr;
631			longcnt = longstore;
632			while(longcnt--)
633				*screenptr++ = 0;
634			rowptr += rowbytes;
635		}
636	#else
637		longcnt = gp->g_display.gd_fbrowbytes * gp->g_display.gd_fbheight;
(gdb) q
Script done on Tue Nov 29 16:21:43 1994

	I'm running System 7.1 with Mode 32 7.5, no extensions (shift
key depressed during boot).  The machine's got 16MB of RAM, and a Micron
Exceed Color 30 video card.  I've got the the menu bar on internal video,
and both displays set to 1 bit mode.  NetBSD boots with the console on
the internal display.  When I try to run dt, it clears the top 60% of
the *external* display, then dumps core.

	I've tried recompiling dt, to no effect.  I'm stumped at this
point, and would be happy to receive a suggestion or two.  I'm looking
forward to getting things working smoothly!

	I seem to remember recent messages on this list concerning the
SE/30 with the Micron card, but I deleted them, thinking I could simply
get them from the mailing list archive.  Unfortunately, the archive on is two months out of date.  Are recent messages available

	By the way, is something wrong on  I tried all day
to get on, but got a "too many users" error each time.  I'd like to
thank Brad Carlson <carlson@Free-Net.Mpls-StPaul.MN.US> for taking the
time to make available to me the FAQ and dt-1.0.

Tres Hofmeister