Subject: ifconfig problem
To: None <>
From: Scott Kaplan <>
List: macbsd-general
Date: 11/05/1994 12:38:32
Okay, I've been doing a little testing of the Ethernet driver for Jeff
Schindall, and in so doing I've discovered an odd problem.  I finally put
all of the correct settings into place--with regards to IP and gateway
addresses and names and such.  When I booted NetBSD, it would get to the
"starting network" point, the machine would turn itself off.  (Note that
when I had incorrect addresses for NetBSD to work with, it just reported
that there was no useable network and gave errors like "bad address", and
continued along with the booting process.)  With the correct addresses, it
behaved just like a Shut Down from the Finder in the MacOS on any Mac that
doesn't have a mechanical power switch (which the IIci doesn't).

So, I tried putting in a blank /etc/netstart file on Jeff's suggestion, and
tried doing some things by hand.  Given the following command, the machine
turns itself off:
ifconfig ae0 inet netmask

These numbers are, I believe, what they should be.  Information, here: I'm
using a IIci, 8 megs of RAM, 128k Micron Xceed cache card, 8-bit Toby frame
buffer video card, and an Apple/3Com EtherLink/NB ethernet card.  Also, I
have the 1.0_BETA binary distribution.  The same problem exists regardless
of the kernel that I use.  I've tried the 0.9C, the old 1.0_BETA (from
10/20/94), the new 1.0 (from a couple of days ago), and my own compiled
kernel with some of Jeff's changes added to source taken from about a week ago.  So, I don't *think* it's a kernel
problem (unless it's one that exists in all of these versions).

I also attempted to take a copy of the ifconfig source from and recompile it.  It compiled quite happily, and then
did the same power-off trick when issued the above line.  (And yes, I
called the newly compiled one explicitly, as "./ifconfig", to avoid letting
the system use the old one.)

This is a truly befuddling problem.  Isn't the call to power down the
machine like this somewhere in the Mac ROMs?  How is MacBSD calling it?
Any ideas?

Scott Kaplan