Subject: Re: Disk problems(LONG!)
To: mike j. laporte <>
From: Greg Ames <tga@maelstrom.Timeplex.COM>
List: macbsd-general
Date: 11/04/1994 10:45:28
Mike J. Laporte writes:

>Mac II, 8ram, 160(ID 0),160(ID 6), 540(ID 1), sys 7.1.  

Do you have any more info about these drives?  Specifically the 540?
Manufacturer, model #, phys size (3.5 or 5.25, FH/HH), approximate

It sounds like the 540 is not "standard SCSI".  Some older drives do
not adhere 100% to the SCSI spec's, and break in marvelous ways.  I
had 2 old (>5 yr) drives (both 5.25" HH), a 340Meg Micropolis, and an
80M Quantum, which would exhibit all kinds of neat failures when I
tried to run them on my Mac, due to gross SCSI protocol violations.

>I'm trying to install onto the 540 drive and am finding some problems:
>When formatting with disk manager mac:
>	Mac error #0
>		-command completed w/o error
>	Drive sense key: 5
>		-Description illegal request
>		- Illegal parameter in command, descriptor block 
>		  supplied is data for command.

This definately sounds like drive flakiness.

>I get this error no matter what options I set, I've got the drive partitioned
>with a 32meg swap(I know  overkill but it wouldnt let me do 16) and
>the rest is root&usr.  I've tried setting the drives to different scsi id's
>booting from a floppy(v6.0.8) moving the drives in the physical chain.

Have you tried removing both of the 160's from the bus?  Does
reordering drives on the bus effect the problem (may indicate
termination problems)?

>This is the error I get when running installer after mkfs'ing:
>	sd0 at ID 0    --> currently the only bsd drive I have, 160meg
>	sd1 at ID 1    --> the 540 I want to make bsd
>	Mounting partition 'A' as /
>	  Failed mountfs(), error 22
>	  Error mounting root
>	  mount root: undefined error
>the installer is kicked up to 1500k as per allen's suggestion.
>These are the same messages I got the other nite when trying to do this on
>a 100meg conner drive.

Again, can you give more info about the Connor drive?

>APS gives me numerous messages all very vague but with the same results
>when running installer.

This info may be helpful.  I have never seen errors from APS, so I don't
how useful they are.

>anyone have any thoughts or ideas?

Try running just the 540 on the SCSI bus (boot from a floppy with APS
on it).  Also double check your termination.  SCSI weirdness is often
caused by improper termination.  Are you using an external terminator
at the end of your chain?  Check to make sure none of the drives have
internal terminators installed (these will count as your final
terminators).  Usually, these are 3 8-pin (I think 8) resistor
networks in sockets on the drive's controller board right next to the
SCSI connector.  They are usually black, tan/brown, or yellow in
color, and about 1 inch long.  If you remove any of these, make sure
you note which way they go in, so you don't re-install them backwards.
I find a dab of white-out on one end of the resistor and that side of
the socket works well.