Subject: Running the newest 1.0 kernel on a IIci
To: None <>
From: Scott Kaplan <>
List: macbsd-general
Date: 11/03/1994 17:43:39
Okay, I grabbed the latest 1.0 MacBSD kernel (put up on 11/3/94), and
here's what happened:

The good: It recognizes all 8 megs of my IIci memory.  Unlike the 0.9C
kernel, it takes the amount of memory to use from the booter (the 0.9C
kernel automatically used everything available), but it uses the full 8
megs successfully when set to use it all.  That's what matters to me!
Also, it recognizes my Kensignton Turbo Mouse.  I can't tell whether or not
this will work in, say, an X environment, but it doesn't crash the system
anymore.  Another bonus!

The bad: My copy of dt doesn't work anymore.  When I tried to run it, I got
a cleared screen, and then:
grfunmmap(79): dev a00 addr 0
grfunlock(79): dev 0 flags 3 lockpid -1
Segmentation fault (core dumped)

For kicks, I grabbed dev-0.00.tar.gz from the progs directory on cray-ymp
(I'm presuming that this is the same as what used to be dt.tar.gz file from
the for_testing directory), and tried to compile it with this new 1.0
kernel.  It seemed to compile fine, and finished with no errors.  However,
the file "dt" had size 0 when the compilation was done.  It seemed to do
all the compiling and linking work, but the results were lost.  Not too
good, I don't think.  If this is something I'm doing wrong, please let me's not a problem I had compiling dt earlier.  (And the version of
dt that I had running worked with 0.9C, the original 1.0, and my own
compiled copied of 1.0 with some ethernet changes for testing...)

That's about it.  If I could get dt working, I would be extremely
happy...Anyone else having problems?